This predicate is misnamed. fork_dict/5 (as in source code forking) would be better: a new fork of the dict is created, after all.
|Did you know ...||Search Documentation:|
Has the behavior as if defined in the following way:
get_dict(Key, Dict, Value, NewDict, NewValue) :- get_dict(Key, Dict, Value), put_dict(Key, Dict, NewValue, NewDict).